установка GTK

Жалоба
Вопрос

checking for extra flags to get ANSI library prototypes... none needed
checking for the BeOS... no
checking for HP-UX... no
checking for pkg-config... (cached) /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for GLIB - version >= 2.28.0...
*** 'pkg-config --modversion glib-2.0' returned 2.28.0, but GLIB (2.26.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
no
configure: error:
*** GLIB 2.28.0 or better is required. The latest version of
*** GLIB is always available from ftp://ftp.gtk.org/pub/gtk/.

выбивает это в конце конфигурации.
глиб стоит 2.28
Дополнение #1 03.04.2011 23:09:56
А как удалить старый глиб?

В процессе 1
Linux 4 года назад 2 Ответов 72 Просмотров 0

Ответов ( 2 )

    0
    6 лет назад
    Ответить

    If pkg-config was correct, then it is best
    to remove the old version of GLib

    Попробуйте так и поступить

    0
    6 лет назад
    Ответить

    Вообще-то все рекомендации по исправлению ошибки указаны прямо в приведенном вами куске листинга:
    1. Удалить более старую версию GLib, т.к. конфигурационный скрипт нашел GLIB (2.26.1)
    2. Вручную указать путь к установленным библиотекам GLib используя переменную LD_LIBRARY_PATH или отредактировав /etc/ld.so.conf
    3. Исправить неправильно возвращаемую версию GLib, поправив конфигурацию pkg-config через переменную PKG_CONFIG_PATH

Ваш ответ